ID Core V2 40 won't connect to computer

Discussion - ID:Core, ID:Core V2 and ID:Core 100/150 amplifiers.
Post Reply
Posts: 1
Joined: Fri May 18, 2018 6:43 am

Fri May 18, 2018 7:07 am

I'm running MacOS Sierra 10.12.6 and my ID Core 40 V2 won't connect to the computer. I've tried every USB port on the 2012 Macbook pro, none work. I tried two different USB cables, no luck.

The Blackstar Insider software is buggy, too. I click the 'Change Password' button but the dialog box stays hidden behind the main interface except for a fraction of a second. Also, the software seems very old in it's design, more like an old web page from the early 2000's than a modern application.

I'm finding this to be a very frustrating situation and I'm getting tempted to just bail on this experience.

Posts: 1
Joined: Fri Jun 01, 2018 2:02 pm

Fri Jun 01, 2018 2:07 pm

I have the same problem with my Core 150. The software knows that there is a 150 connected but it cant load the patches from the amp.
I have a core 20 at home and everything works with the same computer.

The only thing which is strange is the I have something installed from blackstar which I cant deinstall.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 3 guests