solution for id 30/15 will not connect to insider 1.4

Discussion - ID:Series amplifiers.
otter5555
Posts: 34
Joined: Sat Aug 31, 2013 12:08 am

Sun Mar 23, 2014 1:58 pm

since blackstar has refused (for weeks) to respond to any of my emails regarding the failure of 1.4 to connect to my 30 or 15 (or any of the other (many) 30/15's that i have since tried using now 10 different laptops and desktops) i decided to try one more time to find the solution before giving up totally.

the ONLY reason i wanted the 1.4 update was for the tap/new controls feature. i have no use for the software because the id's are so easy to dial in from the panel.

every 30/15 would connect instantly to 1.3 on every computer.

every computer would see the amps and record the amps via usb.

the only software that could not see the amps was 1.4

here is blackstar system requirements for 1.4:

Windows® Requirements:

Microsoft® Windows XP® (Service Pack 3), Windows Vista®, Windows 7® or Windows 8®
Intel® Pentium® 4 2GHz or faster (or equivalent)
1GB RAM or greater
1GB free HDD space
Minimum display resolution of 1024x768
Internet Explorer® 7.0 or later
Microsoft.NET® Framework 4.0 or later (included within Blackstar INSIDER installer)
Microsoft Silverlight® 5.0 or later
Internet connection for accessing the Online Community


EVERY computer met these requirements and more and 1.4 would NOT see the amps.

i went online to see if there was a newer version of:

net.framework and silverlight

silverlight 5 is the latest and all computers had it plus the updates

every computer had net framework 4.0 or later

net framework DOES have a later version, version 4.5.

of course, blackstar says: "Microsoft.NET® Framework 4.0 or later (included within Blackstar INSIDER installer)"

well,

i installed net.framework 4.5 and insider now sees the amps.

i did this to 6 of my laptops and all the laptops now see all the amps.

firmware is updated. all is well.

EXCEPT,

blackstar makes no mention of net framework 4.5 being absolutely mandatory for 1.4 to work. the DO clearly state that 4.0 works and is included with the insider software.

it does NOT work with their software.

it would have been nice if:

blackstar would have responded to emails
blackstar's us reps on the phone actually had any knowledge about the id series
blackstar designers actually had any knowledge about their own software
blackstar actually gave a s##t about customer service

BUT, they dont.

after weeks of this bulls##t, and finally getting the 1.4 firmware installed, i am underwhelmed with the new features that i struggled so hard to get.

i own:
id 15
id 30
ht-1
ht-5r
ht-club 40
ht-dual

i love the above amps/pedals BUT,

i will never buy another blackstar product. their service is possibly the worst i have ever experienced in my 50 years as a gigging guitarist. no company is any better than their service.

i have had GREAT service from:

boss
digitech
line 6
zoom
fractal
kemper
tc
marshall
fender
mesa

so, to sum up, if your computer connected to insider 1.4 with no problems you most likely have net framework 4.5 installed somehow.

if your amp is not being seen by 1.4 you most likely need to install net framework 4.5

i'm done with this sh###y company.

User avatar
PhD
Posts: 88
Joined: Sat Jun 16, 2012 12:00 am

Sun Mar 23, 2014 2:53 pm

Great findings! This will help lots of people. Nevertheless, if I can add something:

- considering blackstar as a sh***y company is, at least to my view, somewhat exagerated: I own a 60 Soloist and an ID:60, and those are just fantastic pieces of hardware.

- nevertheless, the numerous difficulties with the Insider situation clearly reveals 2 points:

1. the customer service management is not at level, they should at least have let customers know what happened, inform on action plan, reply to customers inquiries. The status blackout is not tolerable.

2. the software developers (INSIDER, not firmware) should either be trained, staffed, or ... replaced

There is clearly a important accumulation of issues around INSIDER, and ultimately, it remains the management responsibility.

But I don't think one can not extrapolate to other services/departments. The amps are just great.

Please not also that .NET Framework 4.5 is automatically installed in the OS Windows 8, and .NET Framework 4.5.1 is installed with 8.1, so you won't see those listed in the Programs list.

My few cents

otter5555
Posts: 34
Joined: Sat Aug 31, 2013 12:08 am

Sun Mar 23, 2014 8:43 pm

as i said earlier in the post, i own 5 of their amps
i love them all,

but at some point in any product's life you will need service no matter how great a product is.

check the threads, blackstar has consistently shown that they (for the most part) do not answer support emails. the usa tech support (korg) would like to help but knows nothing useable about the product line. customer service is therefore, abysmal.

and as i said earlier, no company is any better than their customer service.

User avatar
myk.robinson
Posts: 253
Joined: Mon Oct 22, 2012 7:02 pm
Contact:

Sun Mar 23, 2014 8:46 pm

@otter5555, I do hate that you had a poor experience with the Insider software as well as with customer service, but I want to commend you for coming back and posting your findings, as it will likely help someone else who may be having a similar problem, but may not be speaking up.

you went above and beyond, my friend.

otter5555
Posts: 34
Joined: Sat Aug 31, 2013 12:08 am

Sun Mar 23, 2014 10:38 pm

i found that once you get out of the forums and into the real world :) that a large number of id owners could not use the 1.4 update because their amps were not recognized by 1.4.

i personally visited several owners within driving distance and none could use 1.4 but all could use 1.3

when i called korg (blackstar usa tech support) i was told more than once that i and one other owners were the only people having any problem connecting to 1.4

that is total bulls##t and was verified by my contacting many other id owners

anyhow,

now we know at least one solution and if more owners can use the 1.4 software i'm a happy camper :)

User avatar
Jim Belaye
Posts: 102
Joined: Sun Dec 29, 2013 10:33 pm
Location: Canada

Mon Mar 24, 2014 1:17 am

I do not understand about the no reply to the email by the company.
Every time I sent an email to Blackstar I get a response, it takes a while but...
But it is true, that there is a lot of room for improvement with customer service.

I do not have any problem using Insider 1.4 with my ID amp, on Windows 7 64 bits.
I feel sorry for those having problems with it, maybe the amp is defective ?
This software still needs a lot of work, 1.4 is a little bit better than 1.3 but...
That being said the ID amp itself sounds great, the problem is the software.

I agree with otter5555 ... No company is any better than their customer service.

bclarke675
Posts: 16
Joined: Thu Jun 20, 2013 8:37 pm

Mon Mar 24, 2014 7:54 pm

+1 on thanks for posting solution

This gives me more confidence concerning a possible purchase.

User avatar
Sonofarich
Posts: 613
Joined: Thu Feb 24, 2011 1:00 am

Mon Mar 24, 2014 8:21 pm

To the OP...you should have probably posted the solution in the original post (for resolution), rather than creating a new post. It might be a good idea to go back and amend it.

On another note. I'm not defending BS's customer service (it could certainly be better), but I've found it not to be terribly uncommon in this industry. Some are obviously better than others, but often response times are not as quick as we would like. We live in an entitled, 'I want it now" society...especially when it involves our own hard-earned $$. Thankfully, you are at least enjoying their products though. Not sure which is better - great product with lacking customer service or lacking product with great customer service.

Just sayin'...

Signusmedia
Posts: 2
Joined: Wed Apr 02, 2014 7:37 pm
Location: United States

Thu Apr 03, 2014 12:37 am

Unfortunately this fix doesn't help the Mac users out here. Have to keep reminding myself that this is really Blackstar's first entry into a software controlled amp, so I'm sure they contracted an outside source to write the Insider software. As that's the case their own tech support is ill equipped to resolve the issue. I've only had my ID:60 for a week or so, but shouldn't have to buy a Windows machine to use the deep editing features that Insider brings to the table. Also the fact that the developers decided on Silverlight and .NET (not exactly cross compatible) leaves me a little upset. I'm looking into the Mono framework (http://mono-project.com) that Insider for Mac was built on, but it looks like I may have to build from source to have a 64 bit version usable.

I really hope that Blackstar can can fix their support dept. I've worked in software support for over 30 years, and once you loose a customer it's REALLY hard to get them back.

Sheryl

tommytiptree
Posts: 26
Joined: Tue Apr 01, 2014 10:20 am

Mon Apr 07, 2014 10:16 am

What about us poor XP users. We cannot upgrade to .NET 4.5 as it is not compatible with XP. Insider will not launch on my PC. Does that mean buying a new PC to use the full potential of this amp. I do think purchasers should be advised of this before buying.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 7 guests