Blackstark HT-60 mkii 212 buzz/vibration

General Discussion Forum - Voice The Sound In Your Head
Post Reply
contiContiCONTI96
Posts: 2
Joined: Mon Jul 09, 2018 9:49 am

Mon Jul 09, 2018 9:57 am

Hey everyone,

Bought the new HT60 mkii combo in January, the past month I have started to hear a very strange buzz (almost like a rattling, some sort of vibration) when I hit certain notes, F, F# and G. The higher the volume, the more prominent the buzz. I'm certain its not a sound thats being amplified through the speakers. Just sounds like something inside the amp is rattling. The strangest thing is that when I move it to a different room or to other positions, it stops. Only in certain locations of the room does it happen.

Took it to the local amp tech. In classic amp-problem fashion, the buzz didnt occur at all while the tech had the amp for a week so he was unable to locate or fix the problem. I tried to take the screws out the back but still cant seem to remove the rare panel. I'm quite certain the noise is coming from the amp and not from another object in the room.

Does anyone have any ideas of what the noise could be?
Anyone know how to remove the back panel off of these amps?

Any replies highly appreciated.

Gelly1982
Posts: 1
Joined: Thu Jul 12, 2018 7:16 pm

Thu Jul 12, 2018 7:44 pm

having same problem with my amp, was wondering if you found an answer to your question as you have written that a few days ago. please update

contiContiCONTI96
Posts: 2
Joined: Mon Jul 09, 2018 9:49 am

Fri Jul 13, 2018 4:10 pm

Hello, No I haven't. The only solution I found is that it works fine in certain locations. I've started to think that its just the room I use it in to be honest. Maybe the resonance against the floor or something. Does your problem sound similar to mine?

Post Reply
  • Information
  • Who is online

    Users browsing this forum: Baidu [Spider] and 19 guests