Blackstar INSIDER and macOS High Sierra

General Discussion Forum - Voice The Sound In Your Head
User avatar
BDX
Posts: 12
Joined: Sun Jan 19, 2014 3:53 pm

Sat Nov 18, 2017 1:43 pm

Is anyone successfully running Blackstar Insider on a Mac with the latest macOS High Sierra (10.13.1)?

On my iMac (Mid 2011) the software is starting up and running, but I can't get it to connect to my ID:Core Beam. I already tried re-installing Silverlight and Insider, tried all USB-Ports, another user on the Mac and switching on/connecting in all possible orders. Nothing helped.
I got no problems on a different Mac with Sierra 10.12.6, but I need it to work on the my iMac. Any ideas?

Psychotic_Sound
Posts: 1
Joined: Mon Nov 20, 2017 2:45 am

Mon Nov 20, 2017 2:48 am

In the same boat--very frustrating. I've been having issues with the Insider software for a while since updating to High Sierra. Makes me feel like I don't have access to half my amp's functionality anymore as controlling it through the software was a huge draw for me. Blackstar, PLEASE update your software to support High Sierra, I've tried everything to fix on my end to no avail.

User avatar
BDX
Posts: 12
Joined: Sun Jan 19, 2014 3:53 pm

Mon Nov 20, 2017 12:49 pm

I got an answer from Blackstars support. It seems they didn't learn anything in the last years. I had a similar (if not the same) issue with my TVP15 and Insider 1.4. The answer is exactly the same as it was these days. Very disappointing.

Anyways... they told me to try the latest mono framework. But that just ends up with an error message from Insider: "Can't connect to internal process" (or something like that).
They also suggested to
  • try different USB-ports and cables > already did this (and wrote it in my message to the support)
  • assure that I use the main USB ports > there are only four ports and I tried them all; macOS and any other software is able to use the amp as audio device, only the dedicated software does not connect (again)
This answer shows to me, that there seems to be just no knowledge about Macs and their OS and/or software testing (with new OS) seems to be no task for Blackstars software department.

BTW: I also can't understand why Blackstar doesn't just open up a developers account at Apple to get rid of this damn security message when installing Insider. That's just totally unprofressional.

User avatar
Admin
Site Admin
Posts: 182
Joined: Tue Mar 23, 2010 12:00 am
Contact:

Tue Nov 21, 2017 11:18 am

Hey guys,

It has been brought to our attention that MacOS High Sierra has caused some units to no longer connect to the INSIDER software and appears to have also stopped Flash Player operation via the website. We're aware that this is currently only affecting the 4-channel audio models;

- ID:Core 10, 20 and 40 V2
- ID:Core 100 and 150

We are working to resolve this as soon as possible, but for the current time are unable to confirm support for MacOS High Sierra until further notice.

We have tested MacOS Sierra (MacOS version before the recent release of High Sierra) and can confirm that the functionality remains intact, with INSIDER and Webpage downloads working correctly at present.

Apologies for the inconvenience, we will be looking to resolve this in due course.
Customer Support Hub - www.blackstaramps.com/support

User avatar
BDX
Posts: 12
Joined: Sun Jan 19, 2014 3:53 pm

Tue Nov 21, 2017 12:29 pm

Thanks for that clarification.

And I have to admit: Blackstars support was really active in the meanwhile. I had massive correspondence with a very committed staff member. My problem isn’t fixed yet,
but I believe, they will sort something out.

Max Head
Posts: 3
Joined: Wed Nov 22, 2017 10:41 pm

Wed Dec 06, 2017 7:54 pm

Hi,

I seem to have kind of the same problem.
Here's what I posted in the IDCore BEAM section of the forum some days ago:
"I'm using a ID Core BEAM 30.
So I did yesterday and it worked just fine.
When I started it today the Insider Software didn't find the amp. It looks like it doesn't get an USB connection.
My MacBook can find it as an in- and output source in its settings and use it (to play music from Spotify e.g.).
The launched Insider Software doesn't find. It doesn't react to the amp at all.
What's wrong?
I didn't change anything since yesterday except installing Firefox (and uninstalled it again)"

My OS ist High Sierra 10.13.1

Any solutions yet?
Thank you!

mcwells1974
Posts: 1
Joined: Mon Oct 09, 2017 3:49 am

Sun Dec 31, 2017 11:28 pm

Any further progress on this? I am having this issue as well. It was working then after the update to High Sierra it quit...

RollDotHome
Posts: 26
Joined: Thu Jan 04, 2018 9:28 am

Sat Jan 13, 2018 7:53 pm

Getting quite disillusioned trawling through this forum looking for answers and not seeing any helpful responses from Blackstar staff. Very disappointing. Anyone made any progress with this?

AstroCreep77
Posts: 4
Joined: Thu Jan 18, 2018 8:33 pm

Thu Jan 18, 2018 9:07 pm

Add me to the list of disappointed Mac users...

I'm on my 2nd ID:Core 100 (first was dead out of the box). Dropped the cash for the FS-12 thinking it would make it 100x easier to access the built-in patches and any I created, only to learn my less than 3 years old MacBook Air wouldn't run the software. I feel like most of the functionality of my new amp (which sounds amazing, otherwise) is unaccessible without the software. I can cycle through the patches on the amp with the foot switch, but I have no idea what and where they are, so it's a crapshoot. I even considered springing for a low-end Windows laptop just to install the Insider app on it, but for the price of that, plus what I have already spent on the amp and FS-12, I could have gotten another amp that didn't require buggy software to unlock most of its functionality.

I would love to see a solution, or at least some sort of update, very soon.

RollDotHome
Posts: 26
Joined: Thu Jan 04, 2018 9:28 am

Thu Jan 18, 2018 9:17 pm

I’ve had a couple of emails from support but nothing encouraging. Basically just acknowledging the issue and that they’re working to fix it but not timescale.

I pointed out that the beta of Mac OS X High Sierra was available to developers LAST JUNE. They obviously didn’t bother testing their flaky, unsigned software and now are up shit creek. Very disappointing.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 11 guests