Windows 10 wont recognize USB device -ID Core:10 V2

Discussion - ID:Core amplifiers.
Post Reply
Gigglegrass503
Posts: 3
Joined: Thu Jan 03, 2019 9:01 am

Thu Jan 03, 2019 10:38 pm

Spent about an hour with support last night trying to figure this one out, and a good 5 hours of my own troubleshooting.

To sum up the problem:

my HP Windows 10 laptop wont recognize the amp when I plug in the USB. It shows up as an unknown device in my Device Managet and doesnt appear at all in my sound/hardware list.

What I've done:
  • installed/reinstalled .net Framework 4.7.2

    Installed/reinstalled Silverlight

    Tested all 4 USB ports

    Bought a new USB cable

    Ran all windows and HP troubleshooting tried to manually add hardware

    Installed multiple previous versions of Insider

    Factory reset the ID Core:10 V2, and repeated most the steps listed above
A few weird things that happened:
  • I was able to get Insider to see my amp while switching USB ports over and over, but it would show "Amp model not recognized" in the Insider settings

    Recreated this by booting up the ID Core10 v2 while holding down the tap button. A green light appeared in the corner by the Voice nob's LEDs, and heard static/feedback coming through the amp. I was told this is not an intended or necessary boot setting. Weird. It also showed up in my device manager by name while this was happening. See my screenshot.

    In one early test I was able to have Insider 1.8.1 recognize my amp and the button to update the firmware appeared. Clicking it did nothing at all. Four hours of fiddling around and I couldn't make this happen again

I know this forum is mostly dead, and Blackstar has little to no grip on their own software, but if anyone has experienced this and found a solution, PLEASE HELP!
Last edited by Gigglegrass503 on Thu Jan 03, 2019 10:41 pm, edited 1 time in total.

Gigglegrass503
Posts: 3
Joined: Thu Jan 03, 2019 9:01 am

Thu Jan 03, 2019 10:40 pm

Blackstar if you see this, please contact me. I will be happy to provide more details or logs if needed.

Gigglegrass503
Posts: 3
Joined: Thu Jan 03, 2019 9:01 am

Tue Jan 08, 2019 10:14 pm

Well after getting no help and realizing this is a dead community and shitty company....

I fixed my problem.

Bought a BOSS Katana, which comes with way better software and recording capabilities, and they're made by a reputable company, Roland.


See ya Blackstar

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 3 guests