Page 1 of 1

Howdy from Vancouver, Canada

Posted: Tue Apr 02, 2019 8:35 am
by Sham-Rock
I'm new to Blackstar and enjoying my diminutive table-top ID:Core BEAM. Lots of fun sounds and effects from this little power house, BUT ... I'm totally bummed that I cannot run the Insider software on my mac which is running High Sierra. If I had known the functionality was crippled I would not have bought the unit!

"MacOS High Sierra is not currently supported" is a black eye for Blackstar!

C'mon Blackstar, do the right thing and tell us when Insider will be fixed to run on High Sierra? Or at least please give us a work-around!