ID:Core Beam new owner - questions

Discussion - ID:Series amplifiers.
Post Reply
stimresp
Posts: 2
Joined: Tue May 10, 2016 9:48 am

Tue May 10, 2016 10:12 am

Hi there,

New member having just entered the Blackstar universe this week.

On recommendation of a friend, I made a punt for a FLY3 last week. I was so impressed that I ordered an ID:Core Beam a couple of days later.

The ID;Core Beam is a fantastic package for me. Compact, with just the right amount of features. I like that the focus is on a small number of high quality effects. Overall it sounds wonderful and very inspiring to play on.

Two questions if I may:

1) As yet, although I've hooked-up USB and use the latest insider software, the firmware has not been updated. Insider reports that I am using frmware 1.1.1, but hasn't this been updated? I've been unable to find a manual way to update (is it supposed to happen automatically from the software?).

2) Regarding the oft-reported hiss, this isn't a show-stopper for me, but I can see why some people are concerned. My unit hisses - a low frequency background noise that is most noticeable when on my desk. It is internal to the amp. I think this amp is best used from a distance of a few feet, rather than right in front of you. The unit is silent until a cable (Jack, minijack or USB) is plugged-in. I have discounted the possibility of ground loops / mains hum.

As said, I can mostly live with it (I've used much noisier 'vintage' gear) but as-is the acoustic simulator channels in particular emit a very high-pitched whine when engaged, making them virtually unusable. A shame, because they sound really good to me.
Has anyone else got this particular issue? I am tempted to send it back to try another unit, but not if it's a known 'feature'.

Many thanks in advance for any pointers/advice/assurances/criticism.

Cheers,
stim

stimresp
Posts: 2
Joined: Tue May 10, 2016 9:48 am

Tue May 10, 2016 10:51 am

I've partially solved Q1 by holding 'shift' when starting the Insider software.

However, although I am told there is a firmware update available, after I complete the update process I am still at firmware 1.1.1. The 'update' button remains lit.

Is 1.1.1 really the latest BEAM firmware?

Thanks again,
stim

aa5gp
Posts: 1
Joined: Wed Sep 21, 2016 6:38 am
Location: United States
Contact:

Wed Sep 21, 2016 7:14 am

I have an ID core 10 that was purchased in Houston just a few months ago. It does not hiss ever and is as quiet as it could be. I've updated the firmware and the amp is still very quiet. I am at a loss as to why so many people are having the hiss problem but it hasn't been a problem for me. I've used my Martin HJ-38, an American standard Stratocaster, an American standard Telecaster, a Gibson 335 and a Gibson Les Paul with my little ID core 10 without any problem whatsoever. Hope all of you guys with the hiss problem find a solution real soon.

Best of Luck,

aa5gp

johned
Posts: 24
Joined: Fri May 09, 2014 3:15 pm

Tue Sep 27, 2016 1:50 pm

According to this URL : http://www.blackstarinsider.co.uk/releasenotes.php
1.1.1 is the latest f/w
My BEAM is very quiet through the speaker but I did find there was some hiss when connecting the EM out to a PA. I solved this by just micing up the amp and it sounded great.
John

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 26 guests