Clicking Noise through EO

Discussion - ID:Series amplifiers.
User avatar
Sonofarich
Posts: 614
Joined: Thu Feb 24, 2011 1:00 am

Fri Oct 25, 2013 4:27 am

You're preaching to the choir. This is a consistent request from the forumites...for a more focal presence from BS. Although I/we believe it would be wise investment/marketing strategy, it is essentially ignored. Doesn't seem to be a priority...for some reason.

Good luck.

btl
Posts: 2
Joined: Tue Oct 07, 2014 12:53 am
Location: United States

Tue Oct 07, 2014 1:02 am

I realize this thread is over one year old....however, has Blackstar or anyone on the forum uncovered a fix for the digital clicking noise from the emulated output when the IDFS foot switch is connected to the amp?

I'm a new owner of an ID260, and would like to be able to use the EO on the amp for recording under certain conditions....the clicking sound renders the recordings as unprofessional.

Does anyone know if it is a hardware problem (I think likely), or is it potentially something a future firmware updates can address?

User avatar
Admin
Site Admin
Posts: 112
Joined: Tue Mar 23, 2010 1:00 am
Contact:

Tue Oct 07, 2014 2:17 pm

This ‘ticking’ or ‘clicking’ noise that you describe may be due to digital footcontroller data being heard on the Emulated Output – verified if the noise is only audible when a footcontroller is connected. If so, this is something that may be able to be rectified by Blackstar Service or an official Service Centre. Please contact us directly via enquiries@blackstaramps.com to let us know where you are in the world and we can find your nearest approved service centre to look into your particular issue.

Hope this helps.

Blackstar product support

btl
Posts: 2
Joined: Tue Oct 07, 2014 12:53 am
Location: United States

Tue Oct 07, 2014 2:33 pm

Thank you, yes, the digital clicking sound is only occurring when the FS10 foot controller is connected. I'll send a note to Blackstar.

notryt
Posts: 3
Joined: Wed Mar 06, 2019 9:50 pm

Tue Mar 12, 2019 7:06 am

I am wondering if anyone knows if the clicking issue has been addressed.. I just bought an ID:60 head and I also notice the clicking.. I will check later today if by removing the fs10 it also cancels out the clicking. I bought an ID:60 when they first were released and I don't recall it having this annoying clicking noise :roll:

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 11 guests