HT-5RH Blown Resistors

Discussion - HT-5 amplifiers.
Post Reply
scorpion13
Posts: 2
Joined: Thu Jan 19, 2012 1:00 am

Wed Jul 25, 2012 12:49 pm

I purchased my HT-5RH back in January of this year and everything has been going fine until the other night it started to crackle and pop while playing. The tone wasn't there anymore, I was thinking it was the power tube maybe on its way out. This morning I decided to open up the amp and see if it was the tube and to my surprise two resistors were fried. R10 & R39. (See Photo). Looks like I'll be taking a trip out to an authorized service center sometime soon. What is the warranty on something like this? I've only had it for 6 months.

Edit: You'll notice that the resistors were so hot that the color identification rings burned off.

Image

a1terrier
Posts: 192
Joined: Sat Apr 30, 2011 12:00 am
Location: West Yorkshire, England

Wed Jul 25, 2012 3:51 pm

Same with mine. Bought it in Jan, then after a couple of months it started to sound like a log fire crackling. Took it back to shop who sent it back to Blackstar. Returned about a week later, new resistors (r38 & 39) no charge, so yours should be free. Been fine ever since. Good luck.

User avatar
MetalOctane
Posts: 97
Joined: Fri Oct 28, 2011 12:00 am

Wed Jul 25, 2012 7:56 pm

That sucks. I just checked mine, luckily everything looks as good as new.

BobZ
Posts: 22
Joined: Mon Oct 18, 2010 12:00 am
Location: New Jersey

Thu Jul 26, 2012 2:25 am

FYI...

If you ever wanted to install a choke in the amp... R10 is where it would go.... R10 comes out and the wires from the choke
get soldered in there.....

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 10 guests