Search found 767 matches

by KKND
Sat Sep 22, 2012 10:29 am
Forum: HT-5
Topic: So I left my HT5R on standby....
Replies: 11
Views: 12533

Re: So I left my HT5R on standby....

And I did......as suspected, the "common" problem of overheating PCB that leaks high voltage was the problem. One of the resistors was burned completely.

The fix was easy from where I was standing.....now the amp is working again.

:)

by KKND
Wed Sep 19, 2012 7:09 am
Forum: HT-5
Topic: So I left my HT5R on standby....
Replies: 11
Views: 12533

Re: So I left my HT5R on standby....

I am probably "Traveling" Tomorrow to get the amp fixed. The tech told me it can be done in a day!!

by KKND
Mon Sep 03, 2012 11:53 am
Forum: HT-5
Topic: So I left my HT5R on standby....
Replies: 11
Views: 12533

Re: So I left my HT5R on standby....

I should've not waited this long, but I contacted the authorized dealer yesterday. the replay came back stating that it is a manufacturing defect. Blackstar issued a statement to all dealers.......well I gotta drop it now to get it rectified.

FYI
by KKND
Sun Sep 02, 2012 3:11 pm
Forum: HT-5
Topic: So I left my HT5R on standby....
Replies: 11
Views: 12533

Re: So I left my HT5R on standby....

Replaced the tubes. No sound still. The only thing i get is a slight hum once of stand by.

This is frustrating.....any ideas!?
by KKND
Mon Aug 27, 2012 8:29 am
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 79
Views: 175792

Re: New HT5-R - No Sound!

So far I managed to change the fuse, still no sound. I am waiting for the 12bh7. If swapping the tube doesn't fix the problem then I might be in the same boat as u guys!! I am not going to be digging that deep in my, I would rather drive for 5 hours and drop @ the tech's. Although upon snooping arou...
by KKND
Sun Aug 05, 2012 5:49 am
Forum: HT-5
Topic: Valve Advise
Replies: 16
Views: 15088

Re: Valve Advise

Welcome on board.....any tube upgrade will be an enhancement to your tone. but for your specific tonal needs, I may suggest the Groove Tubes 12AX7R (Russian). I found that the JJ did a pretty good job smoothing the amp. Moreover, try an eq in the loop will help.

by KKND
Sun Aug 05, 2012 5:40 am
Forum: HT-5
Topic: So I left my HT5R on standby....
Replies: 11
Views: 12533

Re: So I left my HT5R on standby....

Well, I swapped the 12AX7 since I had a spare and the problem still exists. Until I wait for the 12BH7 to arrive, can some one please guide me on fuses, what type are used on the HT5, where to get them (online) and where to find them on the amp?

Never dealt with fuses before.

Thanks in advance.....
by KKND
Wed Aug 01, 2012 3:11 pm
Forum: HT-5
Topic: So I left my HT5R on standby....
Replies: 11
Views: 12533

Re: So I left my HT5R on standby....

I thought if the fuse(s) are busted, the amp won't turn on at all!!
by KKND
Wed Aug 01, 2012 10:22 am
Forum: HT-5
Topic: So I left my HT5R on standby....
Replies: 11
Views: 12533

So I left my HT5R on standby....

For almost 11 hours. Simply forgot to turn off after playing, went to sleep, woke up and rushed outside, came back home and wanted to jam a little ........flicking the standby off...now sound at all. The amp is dead silent....what could be wrong? I ordered a tube set just in case...hope it is only t...