Search found 9 matches

by markheus
Sat Jul 05, 2014 6:09 am
Forum: ID:Series
Topic: iD 260 Mono line in
Replies: 0
Views: 2265

iD 260 Mono line in

I was curious is anyone has taken this amp apart yet and knew whether the line in jack (that is summed to mono) could be replaced and required with a true stereo jack.
by markheus
Sun Oct 27, 2013 4:00 am
Forum: ID:Series
Topic: Cover for the ID series ?
Replies: 3
Views: 4314

Re: Cover for the ID series ?

Not sure why they don't make them. Here's a link - seems they will ship overseas

http://www.ebay.com/itm/BLACKSTAR-ID-26 ... 53f7448494
by markheus
Sat Oct 26, 2013 1:18 am
Forum: ID:Series
Topic: Cover for the ID series ?
Replies: 3
Views: 4314

Re: Cover for the ID series ?

Search on ebay for it. I bought mine for around $60 and am more than happy with it. It has a nice felt interior and a solid vinyl exterior.
by markheus
Thu Oct 24, 2013 9:18 pm
Forum: ID:Series
Topic: Clicking Noise through EO
Replies: 14
Views: 21520

Re: Clicking Noise through EO

Its interesting because I just picked up the guitar after being absent for a few years. I used to have a GNX4 which ran to FRFR speakers but this time I wanted to get back to my roots by buying an actual amplifier. I did a fair amount of research and narrowed it down to the Blackstar ID and the Fend...
by markheus
Sat Oct 12, 2013 12:07 am
Forum: ID:Series
Topic: Clicking Noise through EO
Replies: 14
Views: 21520

Re: Clicking Noise through EO

Yep - Zero problems with the MIDI footswitch! It works perfectly with no delay. I just wonder if its a defect within the amp or maybe just something in my house. I'll play around some more but use a MIDI Controller in the meantime. I also have the FS-10 footswitch and from the start i didnt like it ...
by markheus
Fri Oct 11, 2013 1:38 am
Forum: ID:Series
Topic: Clicking Noise through EO
Replies: 14
Views: 21520

Re: Clicking Noise through EO

I don't think its specific to the FS 10 footswitch. I have a BOSS Gt-100 that has an amp control function. Basically its a programmable switch that is basically like having a two button footswitch built into the GT-100. I get the exact same clicking when plugged into that.
by markheus
Tue Oct 08, 2013 1:51 am
Forum: ID:Series
Topic: Clicking Noise through EO
Replies: 14
Views: 21520

Re: Clicking Noise through EO

Oddly - if the cable is plugged into the jack but not connected to anything on the other end I don't get the sound. I hooked up headphones directly up to the EO jack but its not really loud to tell whether its there or not. The GT-100 has an amp control switch - basically just a two position foot sw...
by markheus
Mon Oct 07, 2013 6:18 pm
Forum: ID:Series
Topic: Clicking Noise through EO
Replies: 14
Views: 21520

Clicking Noise through EO

I've seen some others posting on this issue so I thought I'd start a new thread. I've discovered the clicking noise when hooking anything up to the foot switch jack. Whether I use the blackstar foot switch my GT 100 I get the high speed clicking noise through the emulated output when plugged into my...
by markheus
Wed Sep 25, 2013 5:39 pm
Forum: ID:Series
Topic: ID260 & Boss GT-100/Multi Effects
Replies: 0
Views: 3720

ID260 & Boss GT-100/Multi Effects

Hi - I've noticed a couple of users in here have the GT-100 and seem to be doing what I would like to do. I love the tones from my amp but am looking for a bit more control - here's a repost of something I wrote on the GT-100 Forum. I'm also not totally decided on which pedal I would like to use. Wh...