Search found 8 matches

by Rosspj15
Sun Aug 26, 2012 12:18 pm
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 81
Views: 92141

Re: New HT5-R - No Sound!

Hi Fred sorry for the late reply been busy. I find the best way to desolder the parts from the pcb is to use solder wick which is available from pretty much every where which stocks electronic components. I find it also helps to have a very good soldering iron which gets very hot. A small good tip o...
by Rosspj15
Thu Aug 23, 2012 10:40 am
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 81
Views: 92141

Re: New HT5-R - No Sound!

Hi mate Glad you got your issue sorted too. Glad it was not just my amp and is def looking like a bad batch of pcbs are to blame for this problem. I am very surprised backstar have not recognised this issue as it seems a very common issue. You would have thought they would inform there retailer netw...
by Rosspj15
Wed Aug 22, 2012 10:21 pm
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 81
Views: 92141

Re: New HT5-R - No Sound!

Well it's fixed and it was a very strange one. Hope you don't mind me posting again but I have browsed this forum for a long time and it has always helped me out so I hope this helps a few people out in the future. So changed the MOSFET no change at all which thought was very strange as when I buzze...
by Rosspj15
Mon Aug 20, 2012 10:09 pm
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 81
Views: 92141

Re: New HT5-R - No Sound!

Yea keep us updated will be interested to see what they say the fault is.
by Rosspj15
Mon Aug 20, 2012 9:22 am
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 81
Views: 92141

Re: New HT5-R - No Sound!

It does look that way to be honest. After looking through the web the problem comes up alot not just on this forum either. Have really lost faith in these amps now they seem to just give up after a few months of light use and i really look after my amps. The same issue has just been raised again on ...
by Rosspj15
Sun Aug 19, 2012 8:48 pm
Forum: HT-5
Topic: New Blackstar HT5RH Not working
Replies: 3
Views: 3753

Re: New Blackstar HT5RH Not working

Looks to b a common problem mate a lot of people's amps just seem to stop working mine did on Friday. But cause I work for a big electronics firm I have some one looking at mine now. There was a burnt out resistor on the board which has been replaced but no change. Think it could be the power tube s...
by Rosspj15
Sun Aug 19, 2012 4:54 pm
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 81
Views: 92141

Re: New HT5-R - No Sound!

This seems to be a very common fault you would think may be bs would sort this out and give some info as to why the resistors are burning out. R39 is the resistor which has gone on mine. Replaced today with a like for like but no change. Buzzed the circuit out from diagrams i found and all seems to ...
by Rosspj15
Sat Aug 18, 2012 11:20 am
Forum: HT-5
Topic: New HT5-R - No Sound!
Replies: 81
Views: 92141

Same as

Hi I have the problem. Left my amp on stand by for about an hour and when I went to use it again there was a burning smell in the room the headphones worked perfect but when I took it of standby nothing out of the speaker. Could get some sounds out of it only nasty sounds at full volume. Only had th...